RIP v2 Advanced Lab

Les 9 routeurs BB1, BB2, BB3 et R1 à R6 ont été configurés conformément à topologie présentée précédemment.

La configuration RIP de base à été en suite ajouté :

conf t
  router rip 
     no auto-summary 
     version 2 
     network 10.0.0.0
end

Vérifications:

R6#show ip route rip
     10.0.0.0/24 is subnetted, 11 subnets
R       10.1.14.0 [120/1] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.13.0 [120/2] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.12.0 [120/2] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.24.0 [120/1] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.45.0 [120/1] via 10.1.56.5, 00:00:03, FastEthernet0/0
                  [120/1] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.111.0 [120/2] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.100.0 [120/2] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.113.0 [120/3] via 10.1.46.4, 00:00:00, Serial0/0.64
R       10.1.112.0 [120/2] via 10.1.46.4, 00:00:00, Serial0/0.64

Timers

La commande « show ip protocols » permet afficher la valeur des timers RIP

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 20 seconds 
Invalid after 180 seconds, hold down 180, flushed after 240 
 Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    Serial0/0.12          2     2
    Serial0/0.13          2     2
    Serial0/0.14          2     2
    Serial0/1             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.14.4            120      00:00:06
    10.1.12.2            120      00:00:05
    10.1.13.3            120      00:00:27
    10.1.100.3           120      00:00:13
  Distance: (default is 120)

Ces valeurs peuvent être ajustés avec la commandes « timers » :

R1#conf t
R1(config)#router rip
R1(config-router)#timers ?
  basic  Basic routing protocol update timers

R1(config-router)#timers basic ?
    <0-4294967295>  Interval between updates

R1(config-router)#timers basic 1 ?
    <1-4294967295>  Invalid

R1(config-router)#timers basic 1 5 ?
    <0-4294967295>  Holddown

R1(config-router)#timers basic 1 5 5 ?
    <1-4294967295>  Flush

R1(config-router)#timers basic 1 5 5 5 ?
    <1-4294967295>  Sleep time, in milliseconds

R1(config-router)#timers basic 1 5 5 5 100 ?

flash-update-threshold

Supprime les mises à jour de la flash si les mise à jour arrivent à périodes régulières

R1(config)#router rip
R1(config-router)#flash-update-threshold ?
    <0-30>   threshold in seconds

R1(config-router)#flash-update-threshold 10
R1#show ip protocols
Routing Protocol is "rip"
  Sending updates every 60 seconds, next due in 42 seconds
  Flash update is suppressed when next update due within 10 seconds
  Invalid after 360 seconds, hold down 360, flushed after 500

Authentification

Rip authentification « clear test » ou « md5 »

no validate-update-source

Contrairement à d’autres protocoles de routage, RIP (et IGRP) n’accepte que des routes de ces voisins comportant un next-hop valide en vérifiant que l’IP utilisée lors de l’update est bien directement connectée
Ce comportement par défaut peut-être modifié :

R1(config)#router rip
R1(config-router)#no validate-update-source 

distribute-list

Il possible de filtrer les réseaux appris (in) ou diffusés (ou) selon la longueur du préfixe

R1#show ip route rip | inc 10.1.111.111
R       101.0.0.0/8 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       102.0.0.0/9 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       103.0.0.0/10 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       104.0.0.0/11 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       105.0.0.0/14 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       106.1.1.32/27 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       107.1.1.0/25 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       108.1.1.64/26 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       109.1.4.0/22 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R       110.1.1.16/28 [120/1] via 10.1.111.111, 00:00:08, FastEthernet0/0
R1#conf t
R1(config)#ip prefix-list NET-OK seq 10 permit 0.0.0.0/0 ge 10 le 26
R1(config)#ip prefix-list BB1 seq 10 permit 10.1.111.111/32
R1(config)#
R1(config)#router rip
R1(config-router)#distribute-list prefix NET-OK gateway BB1 in fa0/0 
R1#show ip route rip | inc 10.1.111.111
R       103.0.0.0 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0
R       104.0.0.0 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0
R       105.0.0.0 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0
R       107.1.1.0 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0
R       108.1.1.64 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0
R       109.1.4.0 [120/1] via 10.1.111.111, 00:00:32, FastEthernet0/0

 

offset-list

« offset-list » permet de modifier le metric des routes annoncées ou reçues, et ainsi d’influencer le routage.
l’interface (in ou out) peut être spécifiée?

Par exemple,
R1 annonce le réseau 101.0.0.0/8 à R2 en incrémentant le metric de 9
R1 annonce le réseau 101.0.0.0/8 à R4 en incrémentant le metric de 10

R1#conf t
R1(config)#access-list 1 permit 101.0.0.0 0.255.255.255
R1(config)#access-list 1 permit 102.0.0.0 0.127.255.255

R1(config)#router rip
R1(config-router)#offset-list 1 out 9 serial 0/0.12
R1(config-router)#offset-list 1 out 10 serial 0/0.14

Vérifications:

R2#show ip route 101.0.0.0
Routing entry for 101.0.0.0/8
  Known via "rip", distance 120, metric 11
  Redistributing via rip
  Last update from 10.1.12.1 on Serial0/0.21, 00:00:14 ago
  Routing Descriptor Blocks:
  * 10.1.12.1, from 10.1.12.1, 00:00:14 ago, via Serial0/0.21
      Route metric is 11, traffic share count is 1

Puisque R2 ré-annonce le réseau 101.0.0.0/8 à R4 en incrémentant de façon naturel le metric de 1,
R4 obtient 2 routes possibles à metric égale pour atteindre 101.0.00

R4#show ip route 101.0.0.0
Routing entry for 101.0.0.0/8
  Known via "rip", distance 120, metric 12
  Redistributing via rip
  Last update from 10.1.14.1 on Serial0/0.41, 00:00:18 ago
  Routing Descriptor Blocks:
  * 10.1.24.2, from 10.1.24.2, 00:00:24 ago, via FastEthernet0/0
      Route metric is 12, traffic share count is 1
    10.1.14.1, from 10.1.14.1, 00:00:18 ago, via Serial0/0.41
      Route metric is 12, traffic share count is 1

ip rip triggered

« ip rip triggered » permet de réduire le trafic RIP sur les liens WAN point à point ou multipoint , seul les changements de topologie seront transmis.

R1#conf t
R1(config-subif)#int s0/0.14
R1(config-subif)#ip rip triggered

passive-interface

R2#conf t
R2(config)#router rip
R2(config-router)#default passive-interface default

R2#conf t
R2(config)#router rip
R2(config-router)#passive-interface fa0/0.24

neighbor

« neighbor » permet de configurer une relation de voisinage RIP exclusivement en Unicast

R2#conf t
R2(config)#router rip
R2(config-router)#passive-interface fa0/0.24
R2(config-router)#neighbor 10.1.24.4

R4#conf t
R4(config)#router rip
R4(config-router)#passive-interface fa0/0
R4(config-router)#neighbor 10.1.24.2

ip rip v2-broadcast

R6#conf t
R6(config)#int fa0/0
R6(config-if)#ip rip v2-broadcast

Vérifications

R6#debug ip rip
RIP protocol debugging is on

R6#
*Mar  4 18:54:50.819: RIP: sending v2 update to 255.255.255.255 via FastEthernet0/0 (10.1.56.5)

ip summary-address rip

Vérifications avant modification :

BB3#show ip route 112.0.0.0
R       112.2.2.0 [120/5] via 10.1.113.3, 00:00:13, Ethernet0
R       112.1.1.0 [120/5] via 10.1.113.3, 00:00:13, Ethernet0

Le router BB2 annonce un /8 au lieu de ces 2 /24

BB2#conf t
BB2(config)#int e0
BB2(config-if)#ip summary-address rip 112.1.0.0 255.0.0.0

Vérifications :

BB3#show ip route 112.0.0.0
Routing entry for 112.0.0.0/8, 1 known subnets
  Redistributing via rip

R       112.0.0.0 [120/4] via 10.1.113.3, 00:00:02, Ethernet0

 

output-delay & input-queue

« output-delay » permet d’introduire un délai entre chaque paquet RIP, afin d’éviter d’engorger le routeur voisin

R1(config)#router rip
R1(config-router)#output-delay ?
    <8-50>  Delay in milliseconds

« input-queue » permet d’introduire un délai entre chaque paquet RIP à la réception :

R1(config)#router rip
R1(config-router)#input-queue ?
    <0-1024>  queue depth
This entry was posted in RIP v2. Bookmark the permalink.

Comments are closed.